John Deere 7920 hydraulics getting weaker

John Deere 7920 hydraulics getting weaker Problems

I have a John Deere 7920 tractor that is about 7 years old now. Two years ago the hydraulic pump started rattling when the tractor was cold and the dealer replaced the main pump (I think it was the hydraulic pump and not the transmission pump … it is an IVT) at a cost of only 10,000 Dollars. Lately we have noticed that the hydraulic system slowly weakens over time. Loader circuits used to run at 1, now we run them at 3. Sprayer wings used to run at 2, now we have to run them at 4. and the sprayer pump used to run fine at 7, now we run work at 9. Has this happened to anyone? A failed pump? Something on the valves? Also from time to time the valves under the rear window seem to buzz. If you play around with the hydraulics a bit, the hum goes away for days or weeks. All of this has me a little worried.

I’m going to check with the dealer’s service manager, but I’ve thought about seeing if any other JD operators have had similar hydraulic issues.

I love the tractor except for the hydraulic system problems.

Mine happened last spring when the planter was working. I couldn’t simulate the problem without using the maximum oil flow and the deadhead of a hydraulic at the same time. Something similar to what the planter does with the VRD running.
The dealer suggested that he change the hydraulic pump, but I thought I would give him another year and this year there has been no problem. Also the problem only existed when the oil was good and hot after a couple of hours of use.
As for the weakening of the hydraulic system we have not experienced it yet, or at least I have not noticed it.

Rate article
Kyle
Add a comment